What does this mean?

If you are seeing answer labels in your interview, with no text where a question would normally be, this can mean one of two things:

  • you have created a question point with labelled answer points but have forgotten to enter any text in the question body, or
  • a reference question you have created has 'broken'. 

In this article we will walk you through the exact steps to follow when a reference question has broken.

Find out which reference question is broken

When you know exactly which reference question is broken, you can consider half your problem as solved!

How to check which reference question is breaking:

  • Go through your interview and try to notice which questions are placed before and after the broken reference question. You will be able to tell from the interview if this question is inside a pack reference or on the main path.
  • By now you would have gotten a rough idea where your broken reference question is. To make sure, jump into the editor and locate the reference questions that have exactly the same answer labels as the one you are seeing in the interview.
  • Type in some obvious text e.g. 'TEST1', 'TEST2' etc into the body of the reference questions you have identified.
  • Now go back and refresh the interview by right clicking and selecting 'Reload frame' and check if the text e.g. 'TEST1' comes up on the interview screen. Keep trying till you see this text on the interview screen. 
  • Once you have located your broken it's a good idea to go into the editor and rename the label to something obvious so that you can easily find your broken reference question when you need to.

How to fix this issue

Here are some checks you can run on your reference question to pinpoint what the problem is, once you know what the problem is, it's almost always an easy fix:

  • Make sure that your answer points in the reference question are exactly the same as the answer points in the question you are referencing. This includes spaces and letter case. 
  • Check that you have referenced the correct question, the image below shows where you can check this.
  • Make sure that you have assigned unique labels to all your questions (so that you are sure you are referencing the correct question. 
  • Check that the reference question passes through the branch that the question that is being referenced is on.

With a bit of simple investigating you will find it easy to fix your broken reference question!

Did this answer your question?